Advanced search

Saeco SUP18 Control brew group

Brew group control thermal problem

osommer

February 10, 2021 07:19 pm

*

Coffee drinker

Group: Mitglieder

Posts: 2

Member No.: 41911

Joined: November 10, 2020

Dear Experts
,I have been trying to repair a Trevi Spidem Automatica SUP18M of a friend for some time now, however the machine is now driving me to despair.
The original problem was a non-working brew group, which was probably stuck.
I have replaced the TIP33C transistor with a TIP35C.
The brew group now runs fine in both directions in test mode, but not when cold in normal mode. After power up, the brew group moves to the brew position (but not at full power (voltage about 18 volts on red-blue) and stays there. Voltage then on red-blue -0.7 volts (indicates polarity switching?) and therefore remains in this position. After a short time the red LED flashes. If I then switch the machine off and on again after about 40 seconds - until the machine is obviously warm - it works normally as long as it is warm (components not boiler!). If I switch it on in this phase (normal operation) it runs the self-test (lower position and then briefly back to the home position) as I know it from other identical machines. I have already tried to replace the Zener diode, but it did not work. The series resistance of the brew group motor between cold and hot is 123 and 120 ohms respectively (when the motor is not running). The varistor seems to be working as well. The 100 ohm resistor is also ok when cold (measuring between base and emitter).
Maybe one of you has another idea how to fix this behaviour.
Kind regardsOtto





Schlawi

February 10, 2021 08:18 pm

*

Advanced

Group: Mitglieder

Posts: 487

Member No.: 14628

Joined: December 26, 2011

Cold solder joint?



--------------------
Bleibt Gesund!

osommer

February 26, 2021 11:25 am

*

Coffee drinker

Group: Mitglieder

Posts: 2

Member No.: 41911

Joined: November 10, 2020

Hello friends,

EDIT.

Error apparently always occurs only when switching on (when components cold) - during self-test.
If the machine is switched on (even for hours), coffee can be brewed immediately, the brew group runs normally. Apparently the time of grinding the coffee is enough to let the brew group control work normally.
Does anyone have an idea?

best regardsOtto