Advanced search

Lever of the brewing unit

The lever can no longer be moved.

Cat Louis

January 27, 2019 01:32 pm


Coffee drinker

Group: Mitglieder

Posts: 1

Member No.: 33598

Joined: January 27, 2019

Hello together!
I have a problem with my Caffeo Barista TS.
After removing my brewing unit, cleaning it and then reinserting it, the lever of the brewing unit can no longer be moved downwards.
The spring that moves the lever or makes it moveable seems to be broken, because if I take out the collecting container I can reach in and move a black round part of the brewing unit to the right and then the lever can also be moved down again.
Furthermore the brewing unit itself is already relatively difficult to put back into the machine, since some time. You have to push it in really hard to be able to push the lever down again to lock it.
When I then have the brewing unit inside, the lever down and turn on the machine, it starts to crack at a certain point. I tried to find out where the cracking came from with the flap open on the side and saw that if the brewing unit pushes the ground coffee to brew it, this silver lever in the brewing unit gets stuck somewhere and that cracks then.
Does anyone know the problem and is there a solution? Would be really grateful for any suggestions. unsure.gif
Greetings, Nicolé


June 17, 2019 02:38 pm


Hello...I have exactly the same problem! If I'm not mistaken, it seems to be a disease of this machine. Is there any other solution than the replacement of the brewing unit?..
.asks a desperate Anne


May 25, 2020 05:17 pm



Have you guys made any progress with this topic yet?
We also have the problem with the crackling and bad restart of the brewing group. All parts do not
look like they are worn out.

Everywhere I've gotten at it, I've been cleaning

and polishing



Unfortunately no success. Felt every 10 times everything goes smoothly, it does not crack,

everything is ok.

Then again the cleaning of the brewing group and the problem

starts again.
Merci, Louisdor.


June 22, 2020 09:48 pm


I have the same problem, get the brew group in well but the lever to lock it is blocked somehow. Anyone got any good advice.


June 29, 2020 09:54 am


Hello everyone
, unfortunately I also have
the problem.

The brewing unit has been removed, cleaned and during installation it jams and the lever for locking/unlocking does not go down anymore. (Unless I turn the "locking roller


provided for this purpose

)Resetting the drive (On button + MyCoffee button) does not help, except for the display of system error 8. Would be very grateful for further useful tips


June 30, 2020 02:29 pm


Got it right with me now.
I put detergent on the drive shaft where the brewing unit is attached, so that it "slips" better. It worked great with that. Brewing unit is back in.


July 13, 2020 10:35 pm


I also had the problem that the brewing unit was difficult to use after cleaning. After several wobbles it worked again, gave off strange crackling noises and the "rubber gearwheel" which is actually located on the driving pin in the machine was gone. This had got wedged in the brewing unit. With a pair of pliers I could pull it out and put it back on the right place, then the brewing unit went in again.


October 10, 2020 09:55 am



Same here. Are there already other solutions?

Thanks & VG,denns


May 08, 2021 01:15 pm


Hi All.
I cleaned out all I could in the region of the driveshaft( the rubber protrusion) with an earbud, then brushed the shaft with a toothbrush and water as well as where it fits in to the brewing unit. This solved the problem.


January 13, 2022 03:29 pm


I think I have finally got it. But it is still difficult. There is a roller at the bottom of the brewing unit. Two "pins" on the inside of the machine that line up with two "pads" on the brewing unit. These push the roller in and allow the locking mechanism to engage. So as Warren said, clean the driveshaft thoroughly, and also the "pads", then push the brewing unit in as firmly as you can, concentrating on the region of the two pads/pins. Once they push up the roller you can unlock and lock the unit in place. Helps to either have someone to hold the machine, or a wall to put it up against (and non-slip shoes!) and the brewing unit still needs a mighty push to get it where it needs to be. Apart from that, still a great coffee machine!