Advanced search

Saeco Exprelia Evo

flow issues during rinse and brew

dkdc530

November 08, 2022 11:59 pm

*

Coffee drinker

Group: Mitglieder

Posts: 2

Member No.: 60128

Joined: November 08, 2022

Hi I'm having slow dispensing problems with my Exprelia Evo

Things I've done:

-Replace the SBS valve (cream valve on top of brew group)
-Ran a descale cycle
-Disassemble and clean the dispenser assembly inside the door
-Test pump #1 and pump #2 in service mode. p/s values are fine
-bypassed the door sensor and ran a brew cycle with the door open. Espresso came out of cream valve, but I'm not sure if if came out as fast as it should or not.

Does anybody have experience (or a video?) with running a brew cycle with the door open so I can see if the espresso flow out of cream valve is ok before it enters the little black tube that sticks out from the back of the door into the cream valve? The e-plus dial is often very hard to turn also.

If I blow through the little black coffee dispenser tube towards the dispenser assembly, it often feels like the airflow is restricted and clears up if I keep blowing through and turning the e-plus dial simultaneously.

dkdc530

November 09, 2022 06:27 pm

*

Coffee drinker

Group: Mitglieder

Posts: 2

Member No.: 60128

Joined: November 08, 2022

Ok i figured it out. The grind is too fine because I didn't calibrate correctly when I reassembled the grinder after replacing the motor a few months ago. Always learning the hard way rolleyes.gif

kaffeechris

November 09, 2022 09:03 pm

*

Expert

Group: Moderatoren

Posts: 1797

Member No.: 24425

Joined: May 29, 2014

Learning by DIY.
Be comforted you are not alone who likes to learn something even if it is sometimes a little more difficult than expected.

Greetings and enjoy your coffee
Chris





--------------------
Alles ist Wiederverwertbar, sogar diese Buchstaben.
Keine Anfragen oder Hilfe, über E-Mail.