Advanced search

EQ7 Plus

There is no coffee at the outlet


September 22, 2020 09:51 pm


Hello, everyone. I have a problem! start button for a coffee pressed, grinder starts, water inlet hisses, some brewing unit moves, seems to build up pressure, but no coffee comes out of the outlet. But that is not always the case, can someone say something about it, or has someone already had the error? Brewing unit is new, from my point of view electronics defective.wub.gif
Greeting Reinhard


March 13, 2021 12:17 pm


I have the same problem, it seems to loose the pressure after the brewing process. I can hear the pressure loss and see steam coming out of the machine in the area of the cleaning tablet insert lid.


July 21, 2021 10:23 am


Coffee drinker

Group: Mitglieder

Posts: 1

Member No.: 44412

Joined: July 21, 2021

I have the same problem. I open the compartment for grinded coffe, put nothing in and press the start button. No water comes out of the coffee outlet.
I have tried replacing the seals on the brew unit. Did not solve the problem.
I have opened the ceramic valve and cleaned it. Did not solve the problem.
The strange thing is that if I run the cleaning process, some water pour out of the coffee jets.
I dismantled the brew unit, and there is a valve with a spring inside the upper body, where the brewed coffee is supposed to flow through. I removed the spring, and water now comes out of the coffee outlet. I have not bothered trying to brew coffee, as I suspect there is no pressure since the valve is missing.
So I have ordered a new pump, which is on its way. If the pump is not at fault, then I suspect the brewing unit will have to be replaced.
I will get back to this thread when the pump is replaced and tested.